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Chapter 1: About this Guide
In This Chapter

• Intended 
Audience

• Conventions

• Getting Help
The Array Imaging System Software is a Windows-based 
software application that provides the ability to lay out and print 
direct mail.

Note: The Array Imaging System Software v3.0 may be installed on 
any Array Imaging System; however, only systems that have been 
upgraded with the 3.0 dongle (hardware key) can print OneCodes 
and at 200 dpi, although these two features may be created in the 
software.

Intended Audience

This guide is intended for use by MCS equipment operators. 

Basic knowledge of the Microsoft Windows® operating system 
and some experience with printing equipment is assumed.

Conventions

The following conventions are used in this guide.

Getting Help

A complete on-line help system is available in the Array Imaging 
System Software interface by selecting the Help item in the Menu 
bar or the Help icon on the toolbar.

If you need further assistance, please contact MCS via e-mail at 
technicalsupport@mcspro.com or call 877.MCS.PROZ 
(877.627.7769). Telephone support for MCS Inc. sold equipment 
is available 8:30am to 6:30pm EST Monday through Friday and 
is free of charge. 

Convention Description

Bold Actions you should take such as text or data to 
be typed exactly or items to click.

Italics Items to type in which you must supply a value.
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Getting Help

About this Guide
Note: To locate your program location and version you can look in your Help>About window 
or select Ctrl-Alt-1 and Ctrl-Alt-2 while in the Job Log window.
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Chapter 2: Getting Started
In This Chapter

• Software 
Installation

• Dongle 
Installation

• First-time 
Installation of 
Device Driver
The Array Imaging System Software is a software application 
that allows you to lay out direct mail pieces and print them. 
Although most of the work you do to create and print direct mail 
pieces is performed through the application interface, you may 
also have to make some physical adjustments to the printing 
equipment in order for your run to print correctly. 

Array Imaging System Software has three main sections: the job, 
the template, and data. You create the job and the template, but 
you have the ability to only manipulate data. Data files are 
supplied to you or by you.

The general steps to producing direct mail through Array Imaging 
System Software are:

1. Import Data. See “Importing Data” on page 4-1.

You must obtain data files.
2. Perform Print Setup.

See “Print Setup” on page 7-1.

3. Create a Template. See “Using Templates” on page 5-1.

A template is the actual layout of the material you wish to print.

4. Create a Job. See “Creating Jobs” on page 6-1.

The job consists of data, a template, and system settings. See 
“System Setup” on page 6-2 to create and enter System Settings.

5. Print the Job. See “Printing Jobs” on page 7-1.

Print test runs and make physical adjustments as necessary to 
ensure print quality.

Software Installation

The first installation of Array Imaging System Software is done 
by an MCS technician at your facility. After that, you are 
responsible for system upgrades.

Minimum system requirements to perform upgrades are:

• Pentium processor
• Windows XP
• 1 GB RAM
• CD ROM drive
2-1



Software Installation

Getting Started
The system should be turned off when installing or uninstalling software.

If an upgrade/downgrade is being performed, the system must be powered-down then up 
again after the new version is installed. This is because the Operating System will not 
know to reload the new device-driver into RAM until the device goes away and comes 
back again. The “Blue-Screen-of-Death” may result upon plug-in if this has not been 
performed.

There is no way to manually install or uninstall the software on a PC by deleting or 
copying files. You must run Setup.exe to install the software.

To install/upgrade the software:

1. Backup existing Array Imaging System Software files. 

Array Imaging System Software job have files have a PJB extension and the templates 
have a PTL extension. Data file extensions depend upon the originating application or 
file type.

2. Uninstall any currently installed version using the Windows Remove Programs 
mechanism for doing so.

Access this window by selecting Start>Control Panel>Add or Remove Programs and 
then select the Array Software. Then click Remove.

The following files will remain in the installation folder after the Uninstall completes:
PenInfo.ini

Pen ink-level and warming information.
Setup.cfg

User-specific setup options.
System.dat

User interface defaults information.

Any or all of these files can be manually deleted or left as is so the new installation will 
use them. All of them will be automatically recreated by the application (with default 
values) if they are not present. 

Note: Later versions may have added settings to Setup.cfg. The only way to see those new 
settings after the new install is by deleting the current setup.cfg, which will force the 
application to create a new “default” setup.cfg the next time it runs.

The uninstall script also removes our device driver from the system:
C:\WINNT\System32\drivers\AT1394.sys

Note that you can right-click on AT1394.sys in “My Computer” or “Windows Explorer” 
to see its version.

3. Disable any anti-virus applications.

You can usually do this by right-clicking the application’s icon in your system tray. 
After Array Imaging System Software installation is complete, be sure to enable your 
virus protection.

4. Run Setup.exe for the version you would like to install.

If you are starting with a zip file, unzip it first to the local hard drive and make sure you 
specify that folders in the zip file be honored when unzipping. Locate the setup.exe file 
and double-click it.
2-2
User’s Manual



Dongle Installation
Getting Started
The installation puts the device-driver for that version in
C:\WINNT\System32\drivers\AT1394.sys

and will overwrite any existing one. This is desired because if you are going back one or 
more versions the “old” device driver is required.

5. Follow the setup wizard.

6. Verify firmware.

Make sure the controller’s formatter boards have the appropriate firmware to accept new 
software. Look at the board numbers in the log are of the Job window when the 
controller is first turned on. The next to the last two-digit number should read "07", 
indicating the updated firmware exists. For example, Board Version: 09020300-07-02.

Dongle Installation

Version 3.0 and higher requires a hardware dongle to use the software. A dongle is a 
hardware device that communicates with the MCS software to allow its use. If you 
attempt to use the software without the dongle installed, it will not function properly. 
You will receive an error stating “Printer Setup Error.”

To install the dongle:

1. From the installing CD, double-click the file DongleInstallation/Hdd32.exe.

This executable installs the drivers to operate the dongle.
2. Follow the instructions.

3. Double-click the file DongleInstallation/DongleReader.exe.

This program verifies driver installation and proper operation.
4. Insert the Dongle into a USB port.

The dongle operates in any USB port; however, an internal port is recommended for 
added security.

First-time Installation of Device Driver 

Although the device driver is installed to the Drivers folder by the Installation script, the 
operating system does not yet know that the driver should be loaded when the controller 
is plugged in for the first time. Plug-N-Play is used to associate that driver with our 
device. The first time the unit is connected to the PC via firewire and powered-on, a New 
Hardware Found window is displayed by the Operating System. The following 
instructions show how to associate our driver with our device (they depend slightly on 
the Operating System and/or Service Pack):

1. At the Welcome to the Found New Hardware Wizard window select Install from a list or 
specific location (Advanced) and click Next. 

You will need to specify where the driver install file is rather than have the Operating 
System try to locate an existing driver. The system needs to access our AT1394.inf file 
to determine how to associate the driver. That file is installed to the application’s folder.

2. Click the Browse button and navigate to select the following folder:
C:\Program Files\PrintMail WideArray\PrintMail WideArray
2-3
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First-time Installation of Device Driver 

Getting Started
or
C:\Program Files\MCS\Array_Software_name

And click OK.
3. Click Finish.

The wizard installs the driver and indicates it completed successfully.

You may verify the driver is installed by locating the “IEEE 1394 Printer” “Array 
Technologies AT-2500 Printer” in the Device Manager (see “Wizard aborted” on page 2-
4 for instructions on getting to the Device Manager). 

Note: The unit must be powered-on and connected.

If the “New Hardware Found” wizard is aborted before it completes, it will not appear 
again on further add/removals of the device! Note that someone else may have already 
aborted the wizard without your knowledge before you did. The wizard is the only way 
the driver can be installed. If the system is in the state where the wizard was aborted then 
nothing appears in the application's log when the system is connected to the PC.

Therefore, the unit should not be connected to the PC before the software is installed or 
before an operator is ready to complete the wizard.

Wizard aborted

If the wizard was aborted you can cause it to reappear the next time the system is 
connected by following these steps:

1. Leave the system on and plugged into the PC.

2. Go to the Device Manager. 

Start>Control Panel>System
3. Click the Hardware tab.

4. Click on the Device Manager button to open the Device Manager.

5. Locate Array Technologies Inc. AT-2500 Printer in the list of devices. 

It should be under the Other devices node and have a question mark icon with an 
exclamation point beside it.

6. Delete the entry from the list by highlighting it and pressing the Delete key.

7. Select Yes or OK from the Confirm Device Removal dialog prompt.

8. Turn the system off.

9. Turn the system on.

10. The New Hardware Found dialog wizard should appear and you can follow the 
directions in “First-time Installation of Device Driver ” on page 2-3 above to associate our 
driver with the device.
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Chapter 3: Understanding the Interface
In This Chapter

• Opening the 
Application

• The Main 
Window

• Title Bar

• Menu Bar

• Toolbar

• Display Area

• Tab Selection 
Area

• Status Bar

• View Menu
Array Imaging System Software is a Microsoft Windows-style 
application. It is important to understand how the interface works 
so that you may use the interface most effectively.

Opening the Application

Array Imaging System Software is a standard Windows 
application and can be opened in many ways, one of which is 
described here.

To open the application:

1. Double click the Array Software icon on your desktop.

The application opens and a splash screen appears.

After a few seconds the splash screen disappears and the Main 
window remains open.

Note: You may open the application using other Windows standard 
techniques.
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The Main Window

Understanding the Interface
The Main Window

The Main Window is the primary point of entry for all tasks. This window is broken 
down into many areas as annotated below. Each area is described in the sections that 
follow.

Title Bar

The Title bar displays the name of the program, a minimize button, a maximize/restore 
button, and a close button.

Title BarMenu Bar

Tab Selection Area
Status Bar

Display Area

Toolbars
3-2
User’s Manual



Menu Bar
Understanding the Interface
Menu Bar 

This standard Windows feature contains pulldown menus to select functions. Functions 
which cannot be used appear dimmed (gray). Items in the Menu Bar are interactive. 
They change as tabs are selected in the tab selection area.

Toolbar 

The Toolbar contains rows of iconic buttons that provide additional functions applicable 
to the displayed window. Icons in the toolbar are interactive. They change as tabs are 
selected in the tab selection area. You can customize the icons displayed in the toolbar as 
described in “Customize” on page 3-5. Default values are shown here for commonly 
used toolbars.

Job and Data Tab

Template Tab

Display Area

The display area is the area in which functions appear. When you select a tab in the tab 
selection area, the display area is repopulated with that information. You then work 
within the display area to execute your tasks.

New Job

Open Job

Save Job

Help

Find

Record Navigation
Go to Record Number

Help

Select Mode

New Record

New Message

Indicia

Bitmap

Conditional BitmapShow Data

Postal Barcode
Barcode

Zoom
3-3
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Tab Selection Area

Understanding the Interface
Tab Selection Area

The tab selection area contains two tabs. The Job and Template tabs provide the major 
functionality for Array Imaging System Software. Selecting a tab changes the display 
area and changes the options available via the menu bar and toolbar. In addition, the Job 
tab has two sub-tabs, Log and Data, which change the display area within the Job 
window.

Status Bar

Located at the bottom of the application window, the Status Bar shows a variety of status 
information.
3-4
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View Menu
Understanding the Interface
View Menu

The View menu contains items that change the way items are displayed on screen. These 
changes apply to all windows in the application.

Data Entry Font

The data entry font selection allows you change the font in which data is displayed on 
screen in application windows. This has no effect on how data is printed.

Note: Only Open Type fonts with True Type outlines may be used in Array Imaging System 
Software. See “Unrecognized Fonts” on page 8-9 for details.

To change the data entry font:

1. Select Data Entry Font from the View menu.

The Font menu appears.

2. Change the font criteria as desired.

3. Click OK.

Customize

The customize option allows you select which icons are shown in the toolbars.
3-5
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View Menu

Understanding the Interface
To change icons displayed in toolbars:

1. Select Customize from the View menu and select the desired toolbar to change.

The toolbar window appears.

2. Use the Add and Remove arrow buttons to change the icons displayed.

3. Click OK.

Options

The options item allows you specify some general preferences.

To specify preferences:

1. Select Options from the View menu.

The Options window appears.

2. Check the box if you wish to save the template with the job and select the number of 
names to show in the recent files list.

3. Click OK.
3-6
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Chapter 4: Importing Data
In This Chapter

• Data File 
Options

• Opening Data 
Files

• Viewing 
Records

• Finding 
Records

• Validating 
Postal 
Barcodes

• Setting Start 
and Stop 
Records

• Changing the 
Data Font

• Field Header
Data files are supplied by customers. Operators cannot change 
data content but can peruse and select data as needed. It is 
important to set data file options so that data is accurately 
imported and printed.

Data File Options

Data file options allow you specify how you want imported data 
to be handled in the application. 

Note: Data file options must be set prior to opening data files.

To enter data file options:

1. Select Data File Options from the File menu.

The File Format Detail window appears.

2. Select the desired file format from the Defined File Types 
pulldown.
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Data File Options

Importing Data
You can provide detail for a variety of file formats including:

3. Enter the remaining parameters for each data file type as indicated above. 

4. Click OK to save your settings.

Custom Data Files

Custom data files require the most configuration because ImagePro800 does not assume 
anything about the file type. Every available data file option is described in this section.

To enter custom data file options:

1. Select Data File Options from the File menu.

The File Format Detail window appears.
2. Select Custom from the Defined File Types pulldown.

File Type Description

Custom Allows you specify custom file format details. All fields are available in this 
format as described in “Custom Data Files” on page 4-2 below.

1 Up format Postal barcode, Sort Description and Code Page fields are available as described 
in steps 6, 7, and 8 below.

Text I Postal barcode, Sort Description and Code Page fields are available as described 
in steps 6, 7, and 8 below. You can also enter a fixed number of fields in the 
Record description.

Text II Postal barcode, Sort Description and Code Page fields are available as described 
in steps 6, 7, and 8 below.

CSV Comma Separated Value formats. These files are typically exported from 

spreadsheet programs like Microsoft Excel®. Postal barcode, Sort Description 
and Code Page fields are available as described in steps 6, 7, and 8 below.

SCITEX The SCITEX proprietary file format. Postal barcode, Sort Description and Code 
Page fields are available as described in steps 6, 7, and 8 below. You can also 
enter a fixed number of fields in the Record Description and enter the field 
description as described in step 5 below.

Database Files exported from database programs such as Microsoft Access®. Postal 
barcode and Sort Description fields are available as described in steps 6, 7, and 8 
below. You can also enter Database Parameters as described in step 3.

Variable Enter variable record and field descriptions as shown in steps 4 and 5 below. 
Postal barcode, Sort Description and Code Page fields are available as described 
in steps 6, 7, and 8 below.
4-2
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Data File Options
Importing Data
The window is repopulated with available fields.

3. Click the radio button for the data source type. 

You can choose either file/text, variable, or database. Select variable or database only if 
you know this file is of that type.

For database file types, enter the Database Parameters Selection Statement only if your 
database has multiple tables and go to step 6. For file/text and variable go to step 4.

Note: The Database Selection Statement is rarely used and you must have knowledge of SQL 
to use it. It requires the SQL statement select * from name.

4. Enter the Record Description.

For File/text select the end-of-record marker or fixed number of fields. 

If you select end-of-record marker, select the end-of-line marker or enter the end-of-
record delimiter. An end-of-line marker will be a carriage return (CR) or line feed (LF). 
A record delimiter is the hexadecimal value for a specific character such as a comma. 
The value for comma (,) is U002C. A pipe (|) is U007C. If you do not know the 
hexidecimal value for your character, see a data processing professional or the internet 
for assistance.

For Variable select the end-of-record marker or fixed length characters and enter the 
Number Of Starting Records to skip. 

5. Enter the Field Description

For File/text select the end-of-record marker or fixed number of fields. 

If you select end-of-record marker, select the end-of-line marker or enter the end-of-
record delimiter. An end-of-line marker will be a carriage return (CR) or line feed (LF). 
A record delimiter is the hexadecimal value for a specific character such as a comma. 
4-3
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Opening Data Files

Importing Data
The value for comma (,) is U002C. A pipe (|) is U007C. If you do not know the 
hexidecimal value for your character see a data processing professional or the internet 
for assistance.

For Variable, use the Add/Modify field definition button to add field level definitions. 
Enter the Field number, starting and ending positions, and field length for each field and 
click OK. The data populates the field description table.

6. Enter the Postal Barcode Description.

Postal bar codes are 12 digits long. They include the zip code plus four, delivery point, 
and a check digit. This area tells the application where to look for this value and to verify 
if it is correct. If you select None, the software will not look for this value. If you choose 
Select From Data, the software looks at all fields for this data. You may also specify a 
field number or the field number along with a specific amount of characters to look at. 
You may also enter postal barcode information as described in “Postal Barcode” on page 
5-16.

Note: If you specify fields to search and there are no postal barcodes in those fields, the 
application will delete data in that field. Specify fields only when you are sure they 
contain postal barcodes.

7. Enter the Sort description.

If you wish printing to pause for sorting purposes, enter the field at which you wish the 
pause to occur. This can be used to create a visual queue for operators. Sort settings are 
also required. See “Sort Tab” on page 7-3 for sort settings. An example sort setting is 
illustrated in the diagram below.

8. Select the Code Page from the pulldown.

These options select the standard used to display text. ANSI-Latin is most often used for 
the american alphabet, but you may need to change this setting.

Note: This field is not applicable to database file types.

9. Click OK to save your settings.

Opening Data Files

Data files must be opened and reviewed as well as attached to jobs. Data files are not 
created in Array Imaging System Software. They are supplied by the printing client and 
can be of a variety of formats. See “Data File Options” on page 4-1 for data file format 
information.

Sort at field X causes 
a pause in printing
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Viewing Records
Importing Data
Note: Path information is saved in jobs. When opening jobs with data files that have previously 
been attached, you may receive error messages if the file no longer resides at the same 
path. If this happens, accept the error messages and open the file from its new location.

To open the data files:

1. Click the Data tab.

You can open Data files with or without the Data tab selected, but you must click the 
Data tab to view the data.

Note: Make sure you have selected the desired Data File Type in the Data File Options window 
prior to attempting to open a data file. See “Data File Options” on page 4-1.

2. Select Open Data Files from the File menu.

The Open Data File window appears.

3. Navigate to the file’s location and click Open.

The file is opened and now populates the display area of the Data tab.

Viewing Records

You can use the Data menu options First Record, Previous Record, Next Record, Last 
Record, and Go To Record to navigate throughout the data file. You may also use the 
record navigation icons on the Toolbar.

Finding Records

You can find specific records using the Find function.

To find records:

1. Select the Job tab and then the Data tab.

2. Select Find from the Data menu.
4-5
User’s Manual



Validating Postal Barcodes

Importing Data
The Find window appears.

3. Enter the desired criteria.

Enter a value to find such as a number or name. Select to search from the current cursor 
location or the whole file and indicate whether to search up or down. If desired, check 
the box to match the case (upper, lower, or mixed) as you typed it.

4. Click Find.

The row is highlighted. You can use the Find Next option in the data menu to find the 
next occurrence of this search criteria.

If you are printing and searched for this item to add to reprints list, click the Add To 
Reprints button. See “Reprints” on page 7-18 for more information on reprints.

Validating Postal Barcodes

If the data file contains postal barcodes and you have placed postal barcodes in the 
template, you can check that the codes are valid in the imported file. The system reviews 
the field specified in the database options window. If the data does not validate, errors 
are listed in the job window.

To validate postal barcodes:

1. Make sure the data file contains postal barcodes.

2. Specify the field in the field containing the barcode in the Data file options window.

You can also highlight the column containing the field.
3. Select the Job tab and then the Data tab.

4. Select Validate from the Edit menu.

Success or failure messages will display in the error log area of the Job window.

Setting Start and Stop Records

You can specify the start and stop records for printing a job. 

To set start or stop records:

1. Select the Data tab.

2. Highlight the desired row for the stop or start record.
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3. Right-click the desired row and select Start Record or Stop Record.

The row number is displayed in the Job window.

Changing the Data Font

You can change the font used to print data. The font change is reflected on screen in the 
data table as well as in print.

Note: Only Open Type fonts with True Type outlines may be used in Array Imaging System 
Software. See “Unrecognized Fonts” on page 8-9 for details.

To change the data font:

1. Select Data Font from the View menu.

The Font window appears. This same window is used for Data Entry font as well.
2. Select the desired criteria.

You can select the font, font size, and weight from the scrolling lists. You can also 
choose a strikeout and underline effect. Leave the script as Western unless you know 
specifically that you need one of the other languages listed. If so, you can click the 
Advanced button for other language options. A sample of the font is displayed in the 
sample box and you can enter specific text in the text box to see how it looks in the font. 
The full character set is displayed in the code page table.

3. Click OK.

Field Header

For data file types with field headers, you can specify what actions to take on field 
headers.
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Chapter 5: Using Templates
In This Chapter

• Creating and 
Saving 
Templates

• Template Setup

• Understanding 
the Template 
Display Area

• Placing New 
Items

• Editing Options

• Viewing Options

• Print Proof
Array Imaging System Software allows you to create templates 
which are the basic design of your print piece. The template 
contains all of the layout information for your piece.

Note: Print Setup as described in “Print Setup” on page 7-1 should be 
performed prior to laying out your template.

Creating and Saving Templates

You can create a new template from scratch, open an existing 
template, and save a template. Template file names are displayed 
in the job window, but are not editable there. Template file names 
appear in red if they have changes that have not been saved. An 
asterick (*) also appears in the title bar if you have unsaved 
changes.

Opening Existing Templates

If you wish to print a template that has already been created or 
make modifications to a template, you must open that template.

To open an existing saved template:

1. Click the Template tab.

2. Select Open template from the File menu.

When you save a template its path information is saved; therefore, 
when you try to open a template and its path information cannot 
be found, you will see a series of error messages. You can accept 
these messages and navigate to the location where the template 
file is now stored. This happens when you share template files on 
different computers. Click Yes on error dialogs and indicate the 
new file path.

The template contains system settings. If you load the Data file 
and Template separately, you may not get all settings associated 
with the template, such as print settings.

Templates have the .ptl extension.

3. Locate the desired file using Windows navigation methods.

4. Click Open.
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The template is opened in the display area. The template name, data file, and template 
file are listed. There is a print button and a variety of status and log information.

Note: You can use the Save As feature to save this template under a new name. All of its 
characteristics are saved and you can use this as a basis for a new template.

Creating New Templates

A new template provides a blank sheet for you to layout direct mail items.

To open a new template:

1. Click the Template tab.

2. Select New template from the File menu.

If an existing template is open, you may receive a message to save that template. The 
template tab’s display area is repopulated and the new template’s title is Untitled.

3. Import Data as described in “Importing Data” on page 4-1, create a template as 
described in “Creating and Saving Templates” on page 5-1, and specify system and print 
settings as specified in “System Setup” on page 6-2 and “Print Setup” on page 7-1, 
respectively.

4. Save the template by selecting Save template from the File menu.

5. Provide a new template name and click Save.

Saving templates

You can save a template that has been opened and modified or that is new.

To save a new template:

1. Click the Template tab.

2. Open an existing template or create a new template.

3. Make any changes.

4. Save the template by selecting Save template from the File menu.

5. Click Save.

Note: You can use the Save As feature to save this template under a new name. All of its 
characteristics are saved and you can use this as a basis for a new template.

Template Setup

Make sure you have set clocks, time stamps, shift definitions, and user inserts before you 
enter items in templates. See “Print Setup” on page 7-1.
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Understanding the Template Display Area

The template display area shows each head board, pen board, and distance between head 
boards. It is important to understand the template so that you can appropriately place 
text and objects.

Head boards are 2 inches and pen boards are 1/2 inch. There are four pen boards to each 
2 inch head board. Each pen board contains a single color ink. Depending on how you 
configure your system, the template layout may differ. For instance if your system is set 
to print two heads together, then four heads together, then two and then six. Your 
template would show white space with 6 blue pen lines (8 half-inch sections for eight 
heads), a grey divider which represents distance from top of piece (as specified in 
“System Setup” on page 6-2) and then the next section with for headboards and so on.

Note: If the items placed in the template do not print as expected, you may need to address 
calibration issues. See “Calibrating Encoder Ticks per Inch, Pen Spacing, Head 
Distances” on page 8-2.

Placing New Items

You can place a variety of items in your template. Once an item has been placed it can be 
edited as described in “Editing Options” on page 5-21. The following section describes 
how to place new items.
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Record Blocks

Record blocks are groups of text generated from your data. Data should be imported 
prior to placing record blocks. Each field of data is a separate line in the block. Field 
numbers are shown when the record block is placed. 

If you wish to see the actual data, click the Show record data icon .

To place a record block:

1. Click the Template tab.

2. Select New Record Block from the New menu.

The text properties box appears with the text tab on top and the full record is placed in 
the template.
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3. Refine the data on the Text tab.

You can delete fields listed in the data display by clicking them. 

You can add fields from the field list by clicking the field name. Fields are added where 
your cursor is placed in the data display. If the field names are not visible, click the 
Select the Fields button to show them. You can also add counters, time stamps, shifts, 
and user inserts by scrolling to the bottom of the field lists and clicking the desired item. 
Click the expansion symbol (+) to reveal the items under each category.

Note: Counters, time stamps, shifts, and user inserts must be created in Print Setup, as 
described in “Print Setup” on page 7-1, prior to invoking this window.

You can highlight fields in the data display and apply text effects such as bold, italic, 
strike through, size, and font.

You can word wrap, remove blank lines when printing, remove leading spaces from 
fields, add additional line spacing, or spread the spacing within the font (Font Width 
multiplier).
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4. Click the Text (more) tab and enter the desired criteria.

If word wrap was selected in the Text tab, you can select character-based word wrap.

Specify how to treat carriage returns and line feeds. Decide whether you want to make 
letters uppercase when printing and remove characters between fields if a field is blank.

5. Click the General tab and enter the desired criteria.
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Enter position and size values. Decide if you want to allow resizing, keep natural size, or 
force square. Most resizing keeps the image constrained to its original proportions. 
Forced square makes the image fit in a perfect square regardless of its original 
proportions. This can be useful if you wish the object to fit inside another square object.

6. Click the Advanced tab and enter the desired criteria.

Click Transparent to make the text transparent. This is selected by default and allows 
you to layer objects. Transparency allows you to see through to the objects below in the 
stack. Enter borders, margins, alignment, and anchor position for the record block.

7. Click OK.

8. Move the item to the desired location via editing techniques as described in “Editing 
Options” on page 5-21.
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If you choose to show data, the record block is populated with data from the data file.

Message Lines

Message lines use the same text entry techniques as record blocks. See “Record Blocks” 
on page 5-4. Instead of the record being displayed in the Data Display box, the words 
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Fixed Text are displayed. Highlight this text and replace it with your desired text. You 
can add record fields to this text to personalize the message.

Conditional Message Lines

Message lines can be conditional. Individual messages can be printed based on the 
conditions you set. For example, if you want a different message printed based on the 
state listed in a particular record field, you must create a message line for each message 
desired. The key to proper conditional message line operation is identical location 
placement and set up of individual messages.

To create conditional messages: 

1. Enter the desired text for the message line as described above.

2. Click the General tab.

3. Physically enter the position of the text.

Note: The position data must match exactly for each text line entered.
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4. Enter the conditional text settings.

You must enter the position. Click the Conditional check box and enter the source field 
and the specific condition for which you want this data displayed. If you select the 
Equal radio button, the specific condition will always be used if the value is found. If 
the value is not found, no text is displayed. If you select the Not Equal radio button, the 
text is displayed only if the source does not match the value displayed. For example, if 
you wish to send a general message such as “Friend,” select the Not Equal function, 
unless you actually have a name value in the field. In either case, conditional items must 
be placed on top of each other in exactly the same position and the Transparent 
checkbox in the Advanced tab must be enabled.

Note: An empty text box is needed for a blank space.

Indicia

Indicia uses the same text entry techniques as record blocks. See “Record Blocks” on 
page 5-4. Instead of the record being displayed in the Data Display box, the standard 
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Indicia is displayed. You highlight this text and replace it with your desired text. You can 
add record fields to this text to personalize the message.

Bitmaps

Bitmaps are graphics files. The only type of graphics that can be imported into Array 
Imaging System Software are monochrome (one color) bitmaps (BMP). You must 
convert other graphic file formats to monochrome BMP prior to importing. You can 
import unconditional or conditional bitmaps.

Unconditional

Unconditional bitmaps are imported and may be resized using the editing tools as 
described in “Editing Options” on page 5-21.

To import an unconditional bitmap:

1. Click the Template tab.

2. Select Bitmap from the New menu.

The open dialog appears.

3. Locate and select the desired file by traditional Windows means.

4. Click Open.

The file is placed in the template and the Bitmap Properties window appears.

5. Make any changes to the bitmap properties by entering information in the tabs.
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The remaining tabs contain the same information described in “Record Blocks” on page 
5-4.

6. Click the General tab.

7. Enter the desired criteria.

You can enter position and size information which dictates how the bitmap are placed.

8. Click the Advanced tab.

9. Enter the desired criteria.

You can enter information about borders and alignment and indicate whether the graphic 
is transparent.

10. Click the Attachments tab.

11. Enter the desired criteria.

If this item has been attached via the attachment options described in “Docking and 
Attaching” on page 5-23, you can modify attachment options. If the item is not attached, 
the items in this tab are not active.

12. Click OK.

Conditional

Conditional bitmaps are several bitmaps associated with a numeric field value in a data 
file. You specify the bitmap to be used, depending on the value in the data file. For 
example, the data file can have a field that indicates a different bitmap for each of 50 
states, depending on where the resident lives. The field value would be 0 to 50. Map the 
the field values to the bitmap so that when the job is run, the correct bitmap is printed, 
based on the state.

Note: The data file must have a field containing conditional bitmap values to use this feature.

To import a conditional bitmap:

1. Click the Template tab.

2. Select Conditional Bitmap from the New menu.
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The Conditional Bitmap Properties dialog appears with the Conditional Bitmap tab on 
top.

3. Click Edit/Add or Quick Add/Update.

Edit/Add should be used when you have bitmaps with alphanumeric names or numeric 
names that are not in ascending numeric sequence. You must enter each bitmap 
individually. A new window appears.

Enter the Bitmap numeric value or browse to select the filename. Click OK. The files 
are added to the table. Click OK. 
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Quick Add/Update is used when all bitmap files have a numeric value in ascending 
order, for example, if you have a number for each state. A new window appears. 

Click Add/Update and navigate to select all the numbered files. Click Open. Values are 
shortcuts specified for the path to the files. Click Done. The files are added in the table. 
The system does the work to match the numbers to the conditions.

4. In both cases, on the Conditional Bitmap tab, check the box if values are numeric and 
select the field in the data file that contains the bitmap number.

The remaining tabs contain the same information described in “Record Blocks” on page 
5-4.

5. Click the General tab.

6. Enter the desired criteria.

You can enter position and size information which dictates how the bitmap will be 
placed.

7. Click the Advanced tab.

8. Enter the desired criteria.

You can enter information about borders and alignment and indicate whether the graphic 
is transparent.

9. Click the Attachments tab.

10. Enter the desired criteria.

If this item has been attached via the attachment options described in “Docking and 
Attaching” on page 5-23, you can modify attachment options. If the item is not attached, 
the items in this tab are not active.

11. Click OK.

The file is placed in the template and can be edited as described in “Editing Options” on 
page 5-21.

Barcodes

Postal or standard barcodes may be placed in your template. All barcodes are limited to 
multiples of 90 degree rotation.
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Standard Barcode

You can choose from a variety of standard bar codes.

To insert standard barcodes:

1. Click the Template tab.

2. Select Barcode and then type of barcode you wish to insert from the New menu.

The Bar Code window appears with the Bar Code tab on top. 

Note: The OneCode selection can be selected and configured for any Array Imaging System 
Software installation; however, it can be printed only if you have the 3.0 (or higher) 
dongle (hardware key). OneCode is the new USPS standard effective 2008.

3. Enter the desired properties for your bar code.

Click the ellipse button to select the text and field for the bar code. Click OK.

Enter sizing, check, and bar information. Check the show human characters box, if 
desired, and enter the desired properties.
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The OneCode window is unique.

The remaining tabs contain the same information described in “Record Blocks” on page 
5-4.

4. Click the General tab.

5. Enter the desired criteria.

You can enter position and size information which dictates how the bitmap will be 
placed.

6. Click the Advanced tab.

7. Enter the desired criteria.

You can enter information about borders and alignment and indicate whether the graphic 
is transparent.

8. Click the Attachments tab.

9. Enter the desired criteria.

If this item has been attached via the attachment options described in “Docking and 
Attaching” on page 5-23, you can modify attachment options. If the item is not attached, 
the items in this tab are not active.

10. Click OK.

Postal Barcode

You can define the properties for Postal barcodes. Postal barcodes are graphical 
representations of a numeric zip code. You may want to keep barcodes within pen 
boundaries as shown in “Avoiding Pen Boundaries” on page 5-22. 
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Note: If you rotate Postal barcodes, make sure the bars do not lay on pen boundaries. Use 
“Avoiding Pen Boundaries” on page 5-22.

To insert standard barcodes:

1. Click the Template tab.

2. Select Postal Barcode from the New menu.

The Postal BarCode window appears with the BarCode tab on top. 

3. Enter the desired properties for your bar code.

Enter the desired dots per inch (dpi) to pitch properties. If you run a bar code’s bars over 
pen boundaries see “Avoiding Pen Boundaries” on page 5-22. You can also try to adjust 
the pitch to 20 bars per inch to avoid pen boundaries.

You can override standard postnet settings by clicking the ellipse button of the postnet 
override. Decide whether you want to allow 5/6 digit codes.

The remaining tabs contain the same information described in “Record Blocks” on page 
5-4.

4. Click the General tab.

5. Enter the desired criteria.

You can enter position and size information which dictates how the bitmap will be 
placed.

6. Click the Advanced tab.

7. Enter the desired criteria.

You can enter information about borders and alignment and indicate whether the graphic 
is transparent.

8. Click the Attachments tab.

9. Enter the desired criteria.
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If this item has been attached via the attachment options described in “Docking and 
Attaching” on page 5-23, you can modify attachment options. If the item is not attached, 
the items in this tab are not active.

10. Click OK.

Counter

Counters use the same text entry techniques as record blocks. See “Record Blocks” on 
page 5-4. Instead of the record being displayed in the Data Display box the words 
Counter:Counter are displayed. Double-click the desired counter field in the field list to 
the left to select it.

Note: Counters, time stamps, shift codes, and user inserts must be created before invoking this 
item. See “Print Setup” on page 7-1 for details. 

Time Stamp

Time Stamps use the same text entry techniques as record blocks. See “Record Blocks” 
on page 5-4. Instead of the record being displayed in the Data Display box the time 
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stamp is displayed. Double-click the desired time stamp field in the field list to the left to 
select it.

Note: Counters, time stamps, shift codes, and user inserts must be created before invoking this 
item. See “Print Setup” on page 7-1 for details. 
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Shift Code

Shift codes use the same text entry techniques as record blocks. See “Record Blocks” on 
page 5-4. Instead of the record being displayed in the Data Display box the shift code is 
displayed. Double-click the desired shift code field in the field list to the left to select it.

Note: Counters, time stamps, shift codes, and user inserts must be created before invoking this 
item. See “Print Setup” on page 7-1 for details. 

User Insert

User Inserts use the same text entry techniques as record blocks. See “Record Blocks” 
on page 5-4. Instead of the record being displayed in the Data Display box the user 
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inserts are displayed. Double-click the desired user insert field in the field list to the left 
to select it.

Note: Counters, time stamps, shift codes, and user inserts must be created before invoking this 
item. See “Print Setup” on page 7-1 for details. 

Editing Options

You can edit placed objects in a variety of ways.

Selecting Objects

You can select objects by clicking them. You can Ctrl-click to select multiple objects. 
Use Edit>Select All to select all of the objects in the template. Invert Selection will 
select all items not currently selected and deselect those items that are selected.
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Moving and Rotating

You can select objects and then move and rotate them. You can move a selected object 
by holding down the left mouse button and moving the mouse. You rotate objects by 
placing the cursor over a corner handle of an object until the rotate symbol appears.

Once this symbol appears left-click and drag to the desired angle. You can also rotate 
and move objects based on setting in the object’s properties dialog as described in 
“Object Properties” on page 5-22.

Note: Some features no longer apply after rotation.

Object Properties

When a single object is selected, you can change a variety of properties for that object by 
selecting Edit>Properties. This is the same properties windows used to place the object. 
See the placement section for each object type for details on each tab on its properties 
window.

Duplicating and Deleting

You can select an object and make an exact copy of it using the Edit>Duplicate 
selection. Click an object and select Edit>Delete to delete the object.

Aligning Objects

You can align objects so that they line up perfectly with respect to each other.

To align objects:

1. Click the Template tab.

2. Ctrl-click to select the objects you wish to align.

3. Select Align and then the desired alignment type from the Edit menu.

Alignment types include top, bottom, left, right, abut top to bottom, and more. The 
objects are moved to the alignment specified.

Avoiding Pen Boundaries

In certain cases, it is not recommended to have objects lay on the blue line pen 
boundaries. This feature moves objects so that they avoid these lines. For example, a 
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barcode that lays on a pen boundary may not print the correct width of the bars that lay 
on the boundary. This could cause the code to scan incorrectly. 

Note: You can also try adjusting the pitch of the barcode to 20 bars as described in “Postal 
Barcode” on page 5-16.

To avoid pen boundaries:

1. Click the Template tab.

2. Click the desired object(s).

3. Select Avoid Pen Boundaries from the Edit menu.

The object is moved to avoid pen boundaries.

Move to Print Area

You can select objects and have them moved to different print areas. Print areas are 
separated by the gray areas that are created by adding distance from top. Each print area 
represents a board or group of boards. The areas are numbered from the top of the 
template to the bottom.

To move objects to a different print area:

1. Click the Template tab.

2. Click the desired object(s).

3. Select Move to Print Area from the Edit menu.

A new window appears.

4. Select the desired print area from the pulldown.

5. Click OK.

The object is moved as specified.

Docking and Attaching

It is often easier to move objects around in the template when they are grouped together. 
Docking and attaching objects helps you move objects relationally.

Docking

Docking objects moves the objects together and groups them. They now act as one 
object and can not be moved independently. 
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To dock objects:

1. Click the Template tab.

2. Ctrl-click the desired objects.

3. Select Dock from the Edit menu.

The items are moved together and can now be moved around as one object.

Attaching

Attaching objects allows you move each object independently but with regard to the 
relationship specified. The objects are not moved together. 

To attach objects:

1. Click the Template tab.

2. Ctrl-click the desired objects.

3. Select Attach (attachment type) from the Edit menu.

The object properties window appears for the first type of item you clicked. The 
attachment properties are recorded with the first object clicked. When objects are 
attached, their attachments tab becomes active in the object’s propertied window.

4. Select the desired type of attachment and specify an offset if desired.

5. Click OK.

The object is moved as specified.
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Layering Objects

Objects may be laid on top of each other to achieve a desired look. The layering of 
objects results in their Z-order.

Note: When using these features, make sure the transparent box is checked in the object’s 
advanced tab properties.

Move to Front/Push to Back

You can move objects to the front and back of a stack as if objects were in a deck of 
cards.

To move objects front or back:

1. Click the Template tab.

2. Click the desired object(s).

3. Select the move option from the Edit menu.

The objects are moved.

Move Up/Down

Once objects are placed in a stack, you can move them up and down within the stack.

To move objects up or down:

1. Click the Template tab.

2. Click the desired object(s).

3. Select the move option from the Edit menu.

The objects are moved.

Set Background

It may be helpful to lay out your template with the actual printed piece as the 
background of your template. When you set a background, the original printed piece is 
placed at the back of the stack of objects but is not editable. It is unclickable. 
Background files can be bitmap (BMP), JPG, or GIF.

To set the background:

1. Click the Template tab.

2. Select Set Background from the Edit menu.

3. Navigate to and select the desired file by traditional Windows means.

4. Click Open.

The file is placed in the background.

5. Select Show Background Image from the View menu to see the image.
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Scanning Data

It is useful to scan data for the longest or largest field content. This will help you to 
provide adequate spacing for the largest content.

To scan for longest content:

1. Click the Template tab.

2. Click the desired record block.

Note: Make sure the show record data button is clicked on the toolbar.

3. Select Scan Data from the Edit menu.

The longest record is displayed in the record block.

Viewing Options

A variety of options under the View menu allows you to see gridlines and colors that can 
assist during layout. You can set the zoom level, show anchor points, show Z-order 
(layered order of objects), show attachments and dock markers, show pen colors (spot 
color editing), and set a grid. For a grid, you can specify whether objects snap to the grid 
and the distance between the vertical lines in the grid.

Print Proof 

You can print to a regular office printer to review the template layout. This does not 
reflect any job settings, just the layout of the template.

To print a template proof:

1. Click the Template tab.

2. Select Print proof from the Edit menu.

3. Enter the desired printing characteristics.

4. Click Print.

5. Select the desired printer.

6. Click OK.
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In This Chapter

• Creating and 
Saving Jobs

• System Setup
Array Imaging System Software jobs are the control center for 
printing. The Job window shows a variety of status information 
and allows you to print the job. A job consists of data, a template, 
and all print and system settings. the creation of jobs and system 
settings is described in this chapter; however, job printing and 
print status are described in “Printing Jobs” on page 7-1.

Creating and Saving Jobs

You can create a new job from scratch, open an existing job, and 
save a job. Job file names are displayed in the job window, but are 
not editable there. Job file names appear in red if they have 
changes that have not been saved. Also, an asterick (*) appears in 
the title bar if you have unsaved changes.

Opening Existing Jobs

If you wish to print a job that has already been created or make 
modifications to a job, you must open that job.

To open an existing saved job:

1. Click the Job tab.

2. Select Open Job from the File menu.

When you save a job its path information is saved; therefore, 
when you try to open a job and its path information cannot be 
found, you will receive a series of error messages. You can accept 
these messages and navigate to the location where the job file is 
now stored. This happens when you share job files on different 
computers. Click Yes on error dialogs and indicate the new file 
path.

The Job contains system settings. If you load the Data file and 
Template separately, all settings associated with the job, such as 
print settings may not be included.

Note: You can adjust setting in the setup.cfg file to allow for portable 
job settings. See “File Control Settings” on page 8-9.

3. Locate the desired file using Windows navigation methods.

4. Click Open.
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The job is opened in the display area. The Job name, data file, and template file are 
listed. There is a print button and a variety of status and log information.

Note: You can use the Save As feature to save this job under a new name. All of its 
characteristics are saved and you can use this as a basis for a new job.

Creating New Jobs

You can create new jobs from scratch.

To open a new job:

1. Click the Job tab.

2. Select New Job from the File menu.

If an existing Job is open, you may receive a message to save that job. The Job tab’s 
display area is repopulated and the new Job’s title is Untitled.

3. Import Data as described in “Importing Data” on page 4-1, create a template as 
described in “Using Templates” on page 5-1, and specify system and print settings as 
specified in “System Setup” on page 6-2 and “Print Setup” on page 7-1, respectively.

4. Save the job by selecting Save Job from the File menu.

You may also click  to save Jobs.

5. Provide a new job name and click Save.

6. You may now print the job as described in “Printing Jobs” on page 7-1.

Note: You can use the Save As feature to save this job under a new name. All of its 
characteristics are saved and you can use this as a basis for a new job.

Saving Jobs

You can save a job that has been opened and modified or that is new.

To save a new job:

1. Click the Job tab.

2. Open an existing job or create a new job.

3. Make any changes.

4. Save the job by selecting Save Job from the File menu.

5. Click Save.

Note: You can use the Save As feature to save this job under a new name. All of its 
characteristics are saved and you can use this as a basis for a new job.

System Setup

System setup is saved when the job is saved and specifies important information about 
how the template relates to the physical setup of the boards.
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Note: Changing system setup after completion of a template may delete objects on the 
template.

You can view and change board and pen settings.

Board Settings

Board settings can be viewed or changed.

To perform system board setup:

1. Select System Setup from the File menu.

2. Click View Boards.

The window repopulates.

3. Indicate if the board is active or inactive by clicking the board’s Active/Inactive field.

4. If your job requires that you join boards, click the first joined board’s Join field. The 
second board’s configuration becomes gray and uneditable.

5. Enter the Distance From Top Of Piece for each board.

This value is calculated by adding the 2 inch value for each board plus half an inch 
between boards. The first board’s value is always 0 since it is at the top. If you have 
connected boards, the distance of both boards is added together and the complete 
distance is placed in the board after the connected board. The distances entered are 
reflected in the template layout. Grey spaces are placed between boards in the template.

6. Enter the Distance From Sensor for each board.

Note: The distance from sensor is an exact measurement of each board from the physical 
sensor on the table top. When the first piece hits the sensor, the system needs to know 
how far away from the sensor to print on each board. You use this distance plus the 
conveyer speed to print on the specified head. You should use alignment boxes as shown 
in “Calibrating Encoder Ticks per Inch, Pen Spacing, Head Distances” on page 8-2 to 
verify these calculations. These distances must be correct for the job to print without 
error.
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Note: Make sure your head boards are perfectly perpendicular to the paper before setting the 
distance from sensor. See “Calibrating Encoder Ticks per Inch, Pen Spacing, Head 
Distances” on page 8-2 for screw alignment.

7. Enter the Feed Direction.

This setting is rarely changed. It overrides the settings in Print Setup. One example of a 
reason to change this setting is printing on the sides of a box. Otherwise, leave the feed 
direction as set in Print Setup.

8. Click OK.

Pen Settings

By default the setup.cfg file controls pen settings and can be accessed manually in your 
installation folder. Initial changes are made via the setup.cfg file. Changes can be viewed 
via the application and future changes can be made via the application.

Initial Pen Setup

This setup is performed manually, without the application. By default no pens are 
created.

To perform initial system pen setup:

1. In your installation directory, open the file Setup.cfg.

This file can be opened in any text editor such as Notepad.

2. Save this file as a new name (such as Setup_old.cfg) using the Save As function in your 
text editor.

3. Open the Array Imaging System Software and notice that a new setup.cfg is created.

4. Close the application.

5. Open this new file in your text editor and make the desired changes.

At the bottom of the file, you see the settings below. There is a section for Boards 1 
through 9. Change the 1 to a 0 in the lines that are bold to enable the board. You will 
need to change these to 0 only for the number of formatter boards that are in the system.

[Board1.Settings]
SensorMargin.Source=0 (0-Job, 1-System)
SensorMargin.System=0.000000
FeedDirection.Source=0 (0-Job, 1-System)
FeedDirection.System=LeftToRight (LeftToRight, RightToLeft)
Pen1.SensorMarginMethod=1 (0-Job, 1-Board, 2-Pen)
Pen1.SensorMargin=0.000000
Pen1.SensorAdjustMethod=0 (0-Job, 1-System)
Pen1.SensorMarginAdjust=0
Pen1.PrintDirection=1 (0-Job, 1-Board, 2-LeftToRight, 3-RightToLeft)
Pen2.SensorMarginMethod=1 (0-Job, 1-Board, 2-Pen)
Pen2.SensorMargin=0.000000
Pen2.SensorAdjustMethod=0 (0-Job, 1-System)
Pen2.SensorMarginAdjust=0
Pen2.PrintDirection=1 (0-Job, 1-Board, 2-LeftToRight, 3-RightToLeft)
Pen3.SensorMarginMethod=1 (0-Job, 1-Board, 2-Pen)
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Pen3.SensorMargin=0.000000
Pen3.SensorAdjustMethod=0 (0-Job, 1-System)
Pen3.SensorMarginAdjust=0
Pen3.PrintDirection=1 (0-Job, 1-Board, 2-LeftToRight, 3-RightToLeft)
Pen4.SensorMarginMethod=1 (0-Job, 1-Board, 2-Pen)
Pen4.SensorMargin=0.000000
Pen4.SensorAdjustMethod=0 (0-Job, 1-System)
Pen4.SensorMarginAdjust=0
Pen4.PrintDirection=1 (0-Job, 1-Board, 2-LeftToRight, 3-RightToLeft)

This example changes the setting for all four pens of Board 1. You need to repeat the 
change for Board 2, Board 3, etc., as needed.

6. Save these changes and close the file.

7. You may now make changes via the application GUI. See “Changing Pen Setup” on 
page 6-5 for information.

Changing Pen Setup

Once pens have been set up, you can make some adjustments via the application.

To view and change system pen setup:

1. Select System Setup from the File menu.

Note: You must have performed Initial Pen Setup for the pen settings to appear editable in this 
window. See “Initial Pen Setup” on page 6-4 for more information.

2. Click View Pens.

3. Adjust individual pen settings.
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Chapter 7: Printing Jobs
In This Chapter

• Print Setup

• Checking Ink 
Levels

• Printing From 
the Job Tab

• Checking Print 
Status

• Reprints
Once the Job is completely set up you can print it. It is 
recommended that you do some test printing before doing the 
complete run. It is especially important to check head alignment 
as described in “Calibrating Encoder Ticks per Inch, Pen 
Spacing, Head Distances” on page 8-2.

Print Setup 

It is important that the job print setup be completed prior to 
printing. System setup should also be completed. See “System 
Setup” on page 6-2. Print setup should be done prior to template 
creation. There are settings in print setup that can be used in the 
template design.

Print Setup Tab

The print setup tab allows you to change the setup of the paper. 
These changes are reflected in the template tab.

To apply print settings:

1. Click the Template tab.

2. Select Print Setup from the File menu.
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3. Click the Print Setup tab.

4. Select the Paper size and Paper orientation.

Height information is needed only if you use landscape orientation.

5. Select the Print Resolution.

Note: You may select any print resolution, but the 200 x 600 selection will print only if you 
have the 3.0 (or higher) dongle (hardware key).

6. Enter the Template Orientation.

The Template orientation should be the same as the Paper Orientation.
7. Enter the Feed Direction and Print Orientation.

The Feed Direction determines which side feeds into the printer. If these settings are 
manually changed in System Setup, this pane turns red. You should verify these settings 
if a color change occurs. Feed Direction rarely changes. One reason to change this 
setting is when printing on the sides of a box. Different feed directions would be needed.

The Print Orientation is which way matter is printed on the paper.

8. Verify your changes in the Template and Printed Piece Preview boxes.

9. Click OK.

Error Tab

The Errors tab allows you to define how errors are reported and logged.
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To specify error settings:

1. Click the Template tab.

2. Select Print Setup from the File menu.

3. Click the Error Setup tab.

4. Enter the desired settings for each type of error.

Each error has a pulldown where you can select to log problems as errors, warnings, or 
information, or not to log them at all. You can also click the Stop Printing checkbox if 
you wish to stop printing when this type of problem occurs.

5. Click OK.

Sort Tab

The Sort tab allows you specify additional sort settings for the pause specified in 
“Custom Data Files” on page 4-2.

To specify sort settings:

1. Click the Template tab.

2. Select Print Setup from the File menu.
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3. Click the Sort tab.

4. Enter the desired criteria.

Enter the amount of space the delay will take on the conveyer. Enter the seconds of the 
pulse sent and the number of pieces the pause will offset.

Counters Tab

The Counters tab allows you to create the Counters that are applied in text properties. 
See “Counter” on page 5-18.

To specify counters:

1. Click the Template tab.

2. Select Print Setup from the File menu.
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3. Click the Counters tab.

4. Click the Add button. 

The Counter Definition window appears.
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5. Enter the counter Name.

6. Select the counter Type.

You can choose Record, Piece or Custom. The custom values are described here as the 
others are subsets of Custom.

Enter the Counter values and what to do if overflow occurs. Decide if counters should 
reset when printing starts

For all types enter the [pad character and length and whether the pad is formatted for the 
region. Select the character set. This setting usually remains Numeric.

7. Click OK.

The counter is added to the counters table.

Time Stamps Tab

The Time Stamps tab allows you to create the Time Stamps that are applied in text 
properties. See “Time Stamp” on page 5-18.

Note: Clocks should be defined prior to defining Time Stamps.

To specify time stamps:

1. Click the Template tab.

2. Select Print Setup from the File menu.

3. Click the Time Stamps tab.

4. Click the Add button. 
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The Time Stamp window appears.

5. Enter the Counter name and description.

6. Select the Clock.

Clocks are created via the Clocks tab. Clocks must be created before Time Stamps.
7. Select the type of time stamp to insert and click Insert.

The definition field is populated. You may change the definition is desired.
8. Click OK.

The counter is added to the counters table.

Shift Definitions Tab

The Shift Definitions tab allows you to create the shift definitions that are applied in text 
properties. See “Shift Code” on page 5-20.

Note: Clocks should be defined prior to creating Shift Definitions.

To specify shift definitions:

1. Click the Template tab.

2. Select Print Setup from the File menu.
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3. Click the Shift Definition tab.

4. Click the Add button. 

The Shift Definition window appears.

5. Enter the shift name and description.

6. Select the Clock.

Clocks are created via the Clocks tab. Clocks must be created before shift definitions.

7. Click Add/Edit.
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A new window appears.

8. Enter the start time and code for the shift.

9. Click OK.

These are entered in the shifts table.
10. Click OK.

The shift is added to the shift definitions table.

Clocks Tab

The Clocks tab allows you to create the Clocks that are applied in text properties as well 
as used to create time stamps and shift definitions.

To specify clocks:

1. Click the Template tab.

2. Select Print Setup from the File menu.

3. Click the Clocks tab.

4. Click the Add button. 
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The Clocks window appears.

5. Enter the clock name and description.

6. Select the clock type.

You can choose to print the current date/time on the record or piece or specify dates.
7. Enter the offset time.

8. Click OK.

The clock is added to the counters table.

User Inserts Tab

The User Inserts tab allows you to create the textual inserts that are applied in text 
properties. See “User Insert” on page 5-20.

To specify user inserts:

1. Click the Template tab.

2. Select Print Setup from the File menu.
7-10
User’s Manual



Print Setup
Printing Jobs
3. Click the User Inserts tab.

4. Click the Add button. 

The User Inserts Definition window appears.

5. Enter the insert name and description.

6. Enter the prompt that users will see to enter this insert.

7. Enter the default value.

8. Click OK.

The insert is added to the inserts table.

Other

The Other tab is used for troubleshooting. It simulates the encoder or sensor to help 
identify encoder or sensor problems.
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To simulate the encoder or sensor:

1. Click the Template tab.

2. Select Print Setup from the File menu.

3. Click the Other tab.

4. Check the boxes to simulate the encoder and/or sensor.

5. Enter the desired simulation parameters.

6. Click OK.

Checking Ink Levels

It is advisable to check ink levels before and during printing. You can also look at ink 
usage statistics.

To check ink levels:

1. Click the Template tab.
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2. Select Ink Levels from the View menu.

3. View the levels.

4. Click the exit icon (X) on your window to close it.

To check ink usage:

1. Click the Template tab.

2. Select Ink Usage from the View menu.

3. View the levels.

4. Click the exit icon (X) on your window to close it.

Printing From the Job Tab

After the following items have been completed you are ready to print the job:

• Data imported
• Template
• Print Setup
• System Setup
• Physical table top alignment

To print the job:

1. Click the Job tab.

2. Enter the print parameters.

These include start piece and stop piece numbers, how many times you want each record 
printed, and whether you want to print test patterns first.
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3. Click Print.

Note: When you are printing a job, all items in all menus become unavailable except Stop 
Printing.

Checking Print Status

The Job window displays a variety of print status information. You can see the current 
record number being printed, how many pieces per hour are printing, the conveyer 
speed, and log information. Log information is displayed in the log window and is color 
coded:

Color Definition

Black Information only

Blue Warning

Red Error
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Changing Print Status Display

This window displays current printing status in the Print Status pane. It displays the 
conveyer speed in the status bar. In both cases you can click on the type of information 
displayed.

To change print status displayed: 

1. Click the Job tab.

2. Click the type of status displayed in the Print Status pane.
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For example, if the status currently displays pieces per hour, click this to change to 
seconds or minutes. You can toggle through the selections.

To change conveyer status displayed: 

1. Click the Job tab.

2. Click the type of conveyer status displayed in the status bar.

For example, if the status currently displays ft./hour, click this to change to seconds or 
minutes or even centimeters. You can toggle through the selections.
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Note: If the conveyer speed becomes too fast, the conveyer speed status turns red and then an 
error dialog appears.
7-17
User’s Manual



Reprints

Printing Jobs
Viewing the Job Log

The job log displays a variety of information while the job prints. Error are shown in red 
and described in “Error Codes” on page 8-11. Blue items indicate warnings and black is 
informational.

Reprints

While you are printing you may notice errors. When you notice errors, you can use the 
find options in the data fields to locate records which need to be reprinted. 

To locate and reprint records:

1. Click the Data tab.

2. Use the Find feature to locate the desired record.

See “Finding Records” on page 4-5.
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3. Right-click the row and select Add to Reprints.

You can also click the Add to Reprints button in the Find window. The selected rows are 
highlighted green.

4. Repeat steps 3 and 3 until all reprints are marked.

5. Click the Job tab.

6. Check the Reprint box.

7. Click Print.

The records are reprinted.
8. Click the Data tab.

9. Right-click anywhere in the data table and select Clear Reprints.

10. Click the Job tab.

11. Uncheck the Reprint box.
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Chapter 8: Troubleshooting
In This Chapter

• Reprogramming 
Boards

• Calibrating

• Pulse-Spitting 

• Smart-Spitting

• Pulse-Warming

• Print inBlank 
Pages

• Unrecogized 
Fonts

• File Control 
Settings

• Ink Bleeding on 
Barcodes

• Error Codes

• Warnings
The following sections can help your troubleshoot printing 
problems. The troubleshooting table below can help you identify 
common problems.

Reprogramming Boards

This feature is accessible from the File menu when the Job tab is 
selected. It is used when a new software version renders a board 
obsolete. Use this option only when you have been notified to do 
so.

Problem Possible Cause Action

Blank pages 
printing

Paper size doesn’t 
match print size

See “Printing Blank Pages” on page 8-8.

Boards not 
operating properly

New software 
version has been 
uploaded

See “Reprogramming Boards” on page 8-1.

Files created on 
another machine 
unable to open 

Files settings need 
adjustment

See “File Control Settings” on page 8-9

Fonts not printing 
or font error 
message

Fonts are 
unrecognized

See “Unrecognized Fonts” on page 8-9

Gaps Calibration errors See “Calibrating Encoder Ticks per Inch, Pen Spacing, Head 
Distances” on page 8-2.

Ink bleeding Pixel width for 
ink dispensing is 
too high

See “Ink Bleeding on Barcodes” on page 8-10.

Ink not dispensing 
correctly. Missed 
sections.

Dried or cold ink 
in heads

See “Pulse-Spitting Implementation” on page 8-5 and “Pulse-
Warming Implementation” on page 8-7 and “Smart-Spitting 
Implementation” on page 8-6.

Items not aligned Calibration errors See “Calibrating Encoder Ticks per Inch, Pen Spacing, Head 
Distances” on page 8-2.

No sort pulse Slot 1 is inactive See “Firewire Hookup” on page 9-1.

Overlaps Calibration errors See “Calibrating Encoder Ticks per Inch, Pen Spacing, Head 
Distances” on page 8-2.

Path not 
recognized

Files settings need 
adjustment

See “File Control Settings” on page 8-9
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Calibrating Encoder Ticks per Inch, Pen Spacing, Head Distances 

You should print some test pages and review them for proper alignment. If you find that 
items printed are not properly aligned, perform the following procedure:

1. Print a test pattern from the inkjet software to see if there are gaps or overlaps of the 
pens within the head. 

If so, it usually means that one side of your cross-piece mounting bracket needs to be 
adjusted to the right or to the left. This will close or open the gap between pens. (Gaps 
and overlaps examples are below.)

2. With your software closed, right-click on the Array Software icon on your desktop and 
select Properties. 

The Properties window appears.

3. Click Find Target. 

This opens the folder where your configuration files reside.

Overlapped Pens
Properly Aligned Pens

Pens with Gaps
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4. Locate setup.cfg and open it with Notepad or Wordpad.

The first few lines of the document look like this:
[System]
PostalBarcodeType=Postnet (Postnet, aus-4-State, jpn-4-state)
DefaultFileType=1upformat (csv, 1upformat, scitex, text1, text2, 

DebugShowImage=0
DebugSaveBitmap=0
FieldReserved=$
EncoderTicksPerInch=303
PenSpacing=303

5. Change the values for Encoder.Ticks and Pen.Spacing to equal 300. 

Be sure to write down the previous values just in case you need to change back.
EncoderTicksPerInch=300
PenSpacing=300

6. Save your changes. 

Keep this file open, because you will go back to it later. Make sure your changes are 
saved – they must be saved to take effect in the software.

7. Start Array Imaging System Software.

8. Click the Template tab.

9. On a blank template, create a large rectangle object on any head on the template:

The easiest way is to place an Indicia object on the template and manually enter its 
width and height in the object’s Properties General Tab (remember to uncheck Force 
Square). Roughly center the box horizontally and vertically on the template for the 
head. 

For a 2 inch head a 7 inch wide by 1.5 inch tall Indicia on an 8.5 by 11 piece works well. 
The wider the width of the box the more accurate the derived values will be.

Note: Use as wide a box as the piece you are running through allows.

10. Save this template.

11. Print a piece and measure the actual printed width of the box (outside edge to outside 
edge). 

Ideally, the box will be 7 inches wide if the encoder is generating exactly 300 ticks per 
inch. If the actual width is not 7 inches then the measured width can be used to calculate 
the true encoder-ticks-per-inch using a simple ratio:
Encoder ticks per inch = (desired width / actual width) x 300

For example, if the actual printed box is 7.125 inches wide:
Encoder ticks per inch = (7.000 / 7.125) x 300
Encoder ticks per inch = 0.9824 x 300
Encoder ticks per inch = 294.72

12. Enter the value calculated in step 11 for the “EncoderTicksPerInch” and “PenSpacing” 
settings in the setup.cfg file. 

Round the value off to the nearest integer (294.72 -> 295). 
13. Save the changes, and open up the Array Imaging System Software again. 

14. Print another 7 by 1.5 inch box to see the effect. 

15. Restart Array Imaging System Software.

The changes will not take effect unless the software is re-started.
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Note: Changing these values will NOT affect the printed width of the box. The box will always 
measure 7.125 inches regardless of values entered. Nothing can be done to correct that 
except to make the encoder generate exactly 300 ticks per inch. This is because the 
image is always rendered at 600 DPI regardless of these settings. These settings are used 
only to generate the proper distance for each pen's offset from sensor and the left and 
right nozzles on each pen's face. They still play a crucial role in print quality and printing 
across pen boundaries.

Note also that although the box width will not change, its position on the printed piece 
will. This is because these settings are used to determine how many encoder ticks per 
inch there are for sensor offsets as well. 

This is why this step should be done BEFORE determining the exact Distance from 
Sensor settings in the System Setup. See “System Setup” on page 6-2.

Once the above value is entered in Setup.cfg for EncoderTicksPerInch and SensorOffset 
you should notice that the vertical sides of the printed box are better aligned across pen 
boundaries. There may still be a small stagger, but it should be minor. You can correct 
this minor offset by changing the “PenSpacing” setting in Setup.cfg for each pen. 
Increasing this setting will “pull” lower pen's print left, decreasing it will “push” lower 
pen's print to the right (assuming left-to-right transport). 

A crucial point to remember is that if the stagger changes from one printed piece to the 
next and is not constant then it means the piece is slipping or the encoder is skipping on 
the belts etc. If this is true then the mechanical cause should be identified and eliminated 
before trying to compensate through software. If the mechanical transport and encoder 
are correct then the stagger should remain constant on all pieces and pens.

16. Once the pens are aligned as closely as possible, you may still need to adjust an 
individual pen or two. That can be done in the setup.cfg on the following lines:
[Board1.Settings]
PulseWidth=
Pen1.SensorMarginAdjust=
Pen2.SensorMarginAdjust=
Pen3.SensorMarginAdjust=
Pen4.SensorMarginAdjust=

Note: The values that are entered for each pen are measured in single pixels. For a left to right 
transport, positive number move the vertical line in your box to the left, and negative 
numbers will move the vertical line to the right. These values should usually be within 5 
(+/-) of 0.

17. Once all the pens have been aligned, the Distance From Sensor setting in the System 
Settings should be set for each head. See “System Setup” on page 6-2.

The same “box” can be used for this purpose. Simply place the box on the template so its 
left edge is 1/2 inch from the left edge of the layout (manually enter into General 
Properties) and adjust the setting such that its printed position matches. Increasing the 
sensor distance moves the box to the left (because each pen waits more encoder ticks to 
print) and decreasing it will move the print right (assuming left-to-right transport).
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Pulse-Spitting Implementation

Pulse-spitting is a method used to purge the pen head nozzles of any dried ink by 
actually firing drops of ink from the pen. Pulse-spitting used in addition to Pulse-
warming provides a robust solution to print quality issues resulting from harsh ambient 
temperatures and/or printing with a pen that has been exposed to air for an extended 
period of time without firing. This explanation is extracted from Array Technologies, 
Inc. documentation.

Theory of Operation

Although the “Print Test-Pattern” option addresses the issue of poor print quality on the 
leading edge of the first printed piece, it does not solve the problem of extended pauses 
during printing. These pauses may result from feeder reloads, jam clearing, etc., and are 
unique because the user never clicks the “Stop” button; therefore, the Test-Pattern is not 
a viable solution.

The spit feature causes the printer to spit X pixels at a distance of Y encoder ticks before 
the piece if and only if the pen has not printed for the past Z seconds. The intent is that 
the spit drops miss the piece to be printed on – by being fired onto the transport, or into 
open air. 

Note that spitting will never occur on the first piece after print commences (use Test-
Pattern instead).

There are settings in the Setup.cfg file used to control the pulse-spitting parameters:

Spit.On=1
Spit.TimeOut=15
Spit.NumberOfPixels=25
Spit.Gap=300
Spit.On (default = 1):
1 = Spitting function is enabled
0 = Spitting function is disabled
Spit.Timeout (default = 15):

Spit trigger time-out in seconds. Only spit before the next piece if the pen has not printed 
for this many seconds. The time measurement is made per pen since its last drop was 
fired.

Spit.NumberOfPixels is the number of full-black strokes to fire when spitting occurs. 
The default is 25.

Spit.Gap is the distance (in encoder ticks) before the piece reaches the pen when spitting 
will occur. For example, if this setting is 300 (the default) and the Spit.NumberOfPixels 
is 25, then the spit will begin 325 encoder tics before the piece reaches the sensor (at 300 
DPI).
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Smart-Spitting Implementation

Troubleshooting
Smart-Spitting Implementation

Smart-spitting can be used to alleviate problems that are encountered when nozzles are 
infrequently fired. This may be encountered when printing descenders or “floating” 
barcodes. Smart-spitting should be used in conjunction with Pulse-spitting. This 
explanation is extracted from Array Technologies, Inc. documentation.

Theory of Operation:

Under normal printing conditions, ink is printed from each nozzle on each piece; a 
nozzle does not have the ability to dry/clog since it is continually printing. Problems 
arise when a jet nozzle is fired infrequently, i.e., it may clog if not fired often.

The Smart-spitting feature keeps a running count of pixels printed; when the pixel count 
falls below a threshold value, nozzles are fired.

There are five settings in Setup.cfg used to control Smart-spitting:

Mode=0 (0-off, 1-spread, 2-edge spread, 3-edge solid)
Range=1,19
TargetPixels=5
CutOff=0
Decay=0.75

These settings determine where the spitting occurs.

There is no default for the range. If the pixel count for this piece falls within this range, 
consider it for Smart-spitting. For example: for processing descenders, this value could 
be “1,50,” for processing floating bar codes, this value could be “50,2000.”.

TargetPixels is the number of pixels to print if necessary. Cutoff is the threshold value. 
When the running pixel count falls below this value, spitting will occur.

The decay setting is used to decrement/decay the running pixel count. At the end of each 
piece printed the pixel count for the current piece and is added the running pixel count, 
and multiplied by the Decay value.

Since multiple Smart-spitting settings/profiles may be needed (one for descenders, one 
for floating bar codes) each profile is stored in its own section in setup.cfg. For example: 

Mode Setting Description

0 No spitting

1 The spitting is spread between the end of the last 
printed pixel on the piece and the edge of the piece.

2 The spitting is spread out along the edge of the piece

3 The spitting occurs at the edge of the piece
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Troubleshooting
[Spit.Descenders]

Note: Spitting occurs on the piece. If this is not desired, change the width of the piece in Print 
Setup.

Pulse-Warming Implementation

Pulse-warming is a method used to maintain the ink in the pen’s head at a constant 
temperature of 45 to 50 degrees Celsius. This helps maintain consistent print quality at 
varying ambient temperatures and minimizes nozzle clogging due to dried ink formed at 
the nozzle orifice. This explanation is extracted from Array Technologies, Inc. 
documentation.

There are settings in the Setup.cfg file used to control the pulse-warming parameters:

Warming.On=1
Warming.Temperature=50
Warming.AmbientTimeOut=20
Warming.On (default = 1):

The warming function can be enabled (1) or disabled (0):

Warming.Temperature (default = 50):

Target head temperature (warming.temperature) is in degrees Celsius. This setting 
should be between 45 and 50 degrees (50 is default). Setting it too high could cause the 
pen to overheat and enter thermal shutdown. If this occurs printing will stop and an error 
will be reported.

Warming.AmbientTimeOut is the time (in minutes) used as a time-out to trigger 
recalibration of the head temperatures to ambient. Default is 20. If no printing has 
occurred for this amount of time when the user begins print, the software will assume 
the heads are at ambient temperature and recalibrate the target head temperature 
accordingly.

Note that the software automatically recalibrates all the pens’ target temperatures the 
first time the user prints after the application is started.   The software also recalibrates 
individual pen(s) whenever a new (or different) pen is detected in any stall at print start.

Pulse-Warming Addendum

This section describes the possible problems that may result if pulse-warming is used 
incorrectly. It is extracted from Array Technologies, Inc. documentation.

For pulse-warming to work correctly, the software must have an accurate baseline 
“reference” reading for each pen. The target warming-point for each pen is calculated 
based on this reference reading. The reference reading must be made at a point when the 
pen’s nozzles are at ambient temperature (the same temperature as the printed circuit 
boards inside the RSI print-head).
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Printing Blank Pages

Troubleshooting
The software automatically makes this reading based on either of two conditions:

1. If a new (or different) pen is detected in any stall since the last time printing was 
performed the software assumes the pen’s nozzles are at ambient temperature and 
recalculates the warming set-point for that pen.

2. If an amount of time greater than that specified in the setup.cfg parameter 
Warming.AmbientTimeOut elapses since “Stop” was pressed for any pen(s), the 
software assumes the pens’ nozzles are at ambient temperature and recalculates their 
warming set points.

These assumptions are safe for normal operating procedures. When “new” pens are 
inserted they typically have not been printed with recently. Also, if printing has not 
occurred for an extended period of time it is safe to assume the heads have cooled to 
ambient temperature.

Note: The pen nozzles cool relatively quickly: however, the temperature decays 
asymptotically. That is, the temperature may drop five degrees Celsius in ten seconds but 
may require five minutes to drop the last degree required to reach ambient temperature.

Problems can occur if a pen nozzles’ temperature is greater than ambient temperature 
when the software makes its baseline measurement. For example, if a pen’s nozzles are 
at 45 degrees Celsius when the software assumes they are at 25 degrees Celsius then the 
pen’s target set-point may incorrectly be set to 70 degrees Celsius when the desired 
target was 50 degrees Celsius. This would result in inferior print quality and may even 
cause the pen to overheat and enter thermal shutdown.

An example scenario would be “swapping pens.” That is, removing two or more pens 
from their stalls and placing them in different stalls. At the next print initiation the 
software will assume “new” pens were inserted and that they are at ambient temperature, 
and recalibrate their thermal set-points. Note that there is no way to reliably detect and 
track the swapped pens.

If thermal shutdown does occur, the software will cease printing with an error 
[06XXYYZZ] reported in the log but no damage will be done to the printer hardware. 
Simply cleaning the pens and waiting for them to cool to ambient should correct the 
problem.

Another side effect of pulse-warming is the fact pulses are being sent to the pens even 
when they are not printing. If warming is enabled, then whenever the transport is moving 
(encoder ticks are being generated) the pens are receiving energy pulses. This means that 
the accepted practice of removing/inserting pens while the transport is moving is now 
more hazardous since the mating pogo-pins may be shorted as a pen contact pad slides 
across them.

Printing Blank Pages

If your paper size does not match the actual piece size, you may see extra blank pages 
print or assume that every other page is printing. Make sure that the Paper Size setting in 
your Print Setup matches the actual size of the piece or less than how often your sensor 
triggers occur. If the page size is larger, the sensor will be missed and extra pages will 
print. This happens most often in a continuous form, but can also happen on a cut sheet 
job.
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Unrecognized Fonts
Troubleshooting
Unrecognized Fonts

Array Imaging System Software recognizes only Open Type fonts with TrueType 
outlines lines. You can add new fonts to your windows system by placing them in the 
Windows>Fonts folder. To check if the font will be recognized, right click the font and 
select Open. The information circled in the diagram below should be shown in the 
window that appears. 

File Control Settings

The setup.cfg file contains settings that are used to control how job files are read when 
they have been created on machines other than the machine you are currently running. 
By default machine specific information is retained in your files. If you want to use 
settings from jobs created on different machines on your current machine you can 
change the following lines for each board. To allow system level information to be 
portable from different machines change the 0 to a 1 for SensorMargin.source. This 
information includes path, margins, and distance from sensor. You can also change the 
feed direction.

[Board1.Settings]
SensorMargin.Source=0 (0-Job, 1-System)
SensorMargin.System=0.000000
FeedDirection.Source=0 (0-Job, 1-System)
FeedDirection.System=LeftToRight (LeftToRight, RightToLeft)
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Ink Bleeding on Barcodes

Troubleshooting
Ink Bleeding on Barcodes

If the amount of ink dispensed is too dense, you may see ink bleeding in your bar codes. 
You can adjust the amount of ink dispensed to eliminate this issue. You modify the 
following lines in the setup.cfg file to reduce the amount of ink dispensed. The number 
is the amount, in pixel width, of ink dispensed.

BarCode.XwidthAdjust=0
BarCode.WideWidthAdjust=0
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Troubleshooting
Error Codes

When calling MCS for help, please note the error code numbers you receive. These are 
helpful to us in tracking and evaluating your error.

==========================================================================
[01 BB 00] - Print Error: Board X doesn't appear to be responding.
EXT_ERR_NO_PEN_PARAMS / ERR_NO_RESPONSE
No pen_params message received from board within 2 secs after print command sent
==========================================================================
[02 BB PP req_cnt] - Print Error: Board X doesn't appear to be responding.
EXT_ERR_NO_REQUESTS / ERR_NO_RESPONSE
Didn't see 2 image requests from pen after 4 secs since sending print command
==========================================================================
[03 BB PP 03] - Print Error: The PC was unable to generate images fast enough.
EXT_ERR_IMAGE_Q_EMPTY / ERR_INVALID_PC_STATE
Pen's print_result=FW_ERR_IMAGE_UNDERFLOW (3)
==========================================================================
[04 BB PP] - Print Error: Board X doesn't appear to be responding.
EXT_ERR_PEN_SYNC / ERR_NO_RESPONSE => [04 BB PP] pen's img reqs lag last pen's.
Number of image_request msgs from pen > 1 behind “last pen”
==========================================================================
[05 BB PP prntResult] - Print Error: Internal error for board X.
EXT_ERR_FIRMWARE / ERR_INVALID_FIRMWARE_STATE
Pen's print_result in image_req msg != 0
  3 = img underflow (pc was unable to generate images fast enough)
  4 = img overflow
  5 = incorrect isoch tag in pld (obsolete)
  6 = packet overflow
  7 = dma unsync (obsolete)
  8 = image unsync (img tag != previous+1)
==========================================================================
[06 BB PP dout bitfield] - Pen X (Board Y, Pen Z) has failed/stopped printing.
EXT_ERR_PEN_FAILURE / ERR_PEN_FAILURE
pen's image_req msg indicates pen dout error:
     1 = warm
     2 = hot
     4 = underVoltage
     8 = overVoltage
    16 = rowShort
    32 = colShort
    64 = A/D done bit missing
==========================================================================
[07 EE 00 XX] - The PC Firewire card's capabilites are inadequate for the printer.
EXT_ERR_FIREWIRE_FAILURE / ERR_INVALID_PC_STATE / WM_PC_ERROR
EE = bitfield of errors:
   1 = Not isoch resource manager capable
   2 = Not cycle master capable
   4 = Does not support isoch operations
   8 = Not bus manager capable
  16 = max async write request < 512 (see XX for actual num)
  32 = max async read request < 512 (see XX for actual num)
==========================================================================
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Warnings

Troubleshooting
Warnings
==========================================================================
[01BB00XX] - Print Warning: Board BB failed to contact head.
XX = observed pen-driver-board's asic id
(asicTotal==0)||(asicTotal>(0x80*4))
==========================================================================
[02BBPPXX] - Print Warning: Board BB to Pen PP interface failed.
XX = observed pen-driver-board's asic id
(asicId==0)||(asicid>0x80)
==========================================================================
[03BBPP] - Print Warning: Board BB, Pen PP - no pen in stall
penId.bits.serialNumber == 0x3fff
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Chapter 9: Hardware Installation
In This Chapter

• Firewire 

• Rack Firewire 
Hookup

• New Head 
Hookup 
Procedure

• Daisy-chaining 
Controllers
This section contains information about installing or replacing 
hardware items related to the Array Imaging System Software 
application.

Firewire Hookup

This section describes the firewire hookup requirements from the 
PC to one or more formatter boards and its relationship to board 
number and the sort output pulse.

The formatter boards obtain their Board Number (as reported in 
the Application’s Log Window on power-up) by their position in 
the firewire daisy-chain from the PC to the formatter boards.

The board number assigned to each formatter board determines 
what data its corresponding head will print. Board 1 should be 
connected to the head closest to the sensor with each successive 
board being connected to the next farthest head from the sensor.

Although it may seem irrelevant which board is assigned any 
given board number, the problem is that only the formatter board 
in slot 0 (the slot closest to the side of the controller) of the rack 
can control the sort output. This presents a problem only when 
the user sets one or more boards Inactive in System Setup. If the 
board in slot 0 is inactive then no sort pulses will be generated by 
the unit. If the firewire is daisy-chained such that board 1 is NOT 
in slot 0 then disabling boards 2, 3, and 4 results in no active 
board in slot 0, hence no sort pulse.

Rack Firewire Hook-up

The following procedure attaches the firewire cards to the boards.

1. Identify Rack slot 0. 

Slot 0 is the slot closest to the side of the controller and furthest 
from the power-supply in the rack.

2. Connect the first firewire from the PC’s firewire card to the board 
in slot 0 (this will be board 1).

3. Connect a 6” jumper firewire from the board in slot 0 to the board 
in slot 1 (this will be board 2).
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New Head-hookup Procedure

Hardware Installation
4. Connect a 6” jumper firewire from the board in slot 1 to the board in slot 2 (this will be 
board 3).

5. Connect a 6” jumper firewire from the board in slot 2 to the board in slot 3 (this will be 
board 4).

Small Enclosure Firewire Hook-up

1. Identify board 1. 

On 4” small enclosure units (two formatter boards) board 1 is the board furthest away 
from the edge of the unit (inner-most formatter board). On 2” small enclosure units (one 
formatter board) it is not an issue.

2. Connect the first firewire from the PC’s firewire card to board 1.

3. Connect a 6” jumper firewire from board 1 to board 2.

When daisy-chaining racks or small enclosures follow the same procedure for the first 
unit and substitute the last formatter board in that unit for the PC for instructions on 
hooking up the remaining units. Note that “board 1” in each unit will generate sort 
pulses if wired correctly.

Note that systems that have been working properly since their initial installation can fail 
to operate properly when you switch from a software version.

New Head-hookup Procedure

For rack systems, the “first” formatter board must be connected to the head closest to the 
sensor and the remaining formatter boards should be connected to heads increasing in 
distance from the sensor. 

For the small enclosure units the fire-wire daisy chain determines the board order. The 
fire-wire starts with the PC and connects to board 1; the fire-wire leaves board 1 and is 
connected to board 2, etc. The rule that the head closest to the sensor must be connected 
to board 1 is still true; however, board 1 is now defined as the board connected to the PC 
as opposed to being the “first” board in the rack.

Daisy-chaining Controllers

Daisy-chaining units is defined as using two or more units to make-up one “system.” For 
example a 4" small enclosure unit can be daisy-chained with a 2" small enclosure unit to 
make a 6" system. This is accomplished by daisy-chaining the fire-wire from the PC to 
unit 1 - board 1, then unit 1 - board 2, then unit 2 - board 1. The encoder and sensor are 
daisy-chained with a special DB9-to-DB9 ribbon cable provided by Array Technologies. 
This cable allows the encoder and sensor to be connected to unit 1 only. The cable feeds 
the encoder and sensor from unit 1 to unit 2. There is currently no limit to how many 
units can be daisy-chained other than the total print area cannot exceed 14" and a 
different encoder/sensor daisy-chain cable is required for each number of units (the 
cable for daisy-chaining two units will not work for daisy-chaining three units, etc.). 
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Note also that the AC power can also be daisy-chained to multiple units such that the 
power-switch on unit 1 will control AC power to all other daisy-chained units. This is 
accomplished with a special “female-to-male” AC cord (available from Array 
Technologies) and leaving the power-switch in the “ON” position for all units except the 
first unit - which now controls the power for all.
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